NAT Hairpining NAT Hairpining

Topic: NAT Hairpining

Post NAT Hairpining
by ebiscaia on 2021年5月28日

Hi,

Does Dynu have any CNAME service? I'll post the discussion I'm having with TPLink support to simplify things here.

Best regards,

Eduardo

------------------------------------------------------------------------------------------------------------------Hi,

Searching on the internet, the function I'm after is called NAT hairpining.

Best regards,

Eduardo

------------------------------------------------------------------------------------------------------------------

Dear Customer



This email is regarding your recent feedback on Archer VR500v issue.

I am under the impression that you were able to access your Raspberry Pi server from WAN side but unable to do so from a local host?





I am hoping to gather some more information to assist you further regarding this matter.



Were you able to access the server from a local host when:

using WAN domain name +port?
Using WAN IP + port?
Please let me know the results😊
Please provide me with high level network diagram, include the clients, the server, and the service on it.( Ip address assigned as well please)



Would be good if you can include the protocols and ports being used as well.



Looking forward to hear from you.

------------------------------------------------------------------------------------------------------------------

Hi Joe,



Between my first contact with TP-Link and this one I bought an access point, so I tried a couple of things:



- All tests were taken with the Raspberry Pi connected to the router

- Connect using private IP (192.168.1.200/backup) with notebook connected to the router: works

- Connect using private IP with notebook connected to the access point: works

- Connect using private IP with notebook connected to a hotspot: not working, but expected



- Connect using public IP (http://101.112.91.225/backup/) with notebook connected to the router: not working, not desired

- Connect using public IP with notebook connected to the access point: works

- Connect using public IP with notebook connected to a hotspot: works



- Connect to the address (http://brazausrouter.ddnsfree.com/backup/): works

- Connect to the address with notebook connected to the access point: works

- Connect to the address with notebook connected to a hotspot: works




However, I can only connect remotely the Raspberry Pi using the address if I used my notebook connected to a hotspot

ssh ubuntu@brazausrouter.ddnsfree.com -p 2200




Also, I attached a diagram to help to visualize the situation. For the bottom diagram red arrows with a cross is the current

situation. Red arrows with no cross are the way connection was meant to be.




This explains a bit my problem: https://en.wikipedia.org/wiki/Hairpinning




Best regards,




Eduardo

--------------------------------------------------------------------------------------------------------------

Hi Eduardo



Sorry for late reply &

Thanks for the details.



Only settings on this router that might help would be setting up Static routing, but I guess this is not ideal since your public ip is dynamic and might change overtime.



Just a thought: does ddnsfree allow you to add a sub-domain or a CNAME pointing to your internal ip?

Such as: internal. brazausrouter.ddnsfree.com

your local devices can access via this sub-domain instead?



I am also discussing with our engineer to see if there’s any other work around, will be in touch.

Reply with quote | Report
2021年11月27日 14:25
Loading...